We are experiencing a service downtime impacting all Leapsome API's.
Resolved
Jan 22 at 07:30pm CET
Incident Summary & Timeline
On January 20, 2025, starting at 14:47 CET, our platform experienced a major disruption when a malfunction in an AWS infrastructure process blocked auto-scaling, hardware rotation, and deployment tasks. Our monitoring and alerting systems worked as intended, notifying our on-call team promptly. However, because our usual rapid-response mechanisms were unavailable, the team performed manual intervention and a partial rebuild of key infrastructure components in parallel to restore operations. Full services were reactivated by 16:25 CET.
Maintenance Mode
To protect data integrity and maintain system reliability, we placed the platform in maintenance mode once it became clear a quick fix was not feasible. A status page link on the maintenance screen informed about updates while we worked on the repairs.
Recovery & Post‐Maintenance
Even after resolving the primary issue, we had to process a backlog of tasks that had accumulated during the downtime. This required traffic shaping, cluster/service scaling, and other performance optimisations, resulting in slower response times for up to 45 minutes following service restoration. We prioritised minimising any impact on your workflows, and all systems returned to normal shortly thereafter.
Looking Ahead
We continue to refine our infrastructure configurations and will maintain a full standby environment to allow for swifter recovery in the future and when regular procedures fail. In addition, we’re coordinating closely with AWS to prevent a repeat of these issues. We appreciate your patience and partnership as we focus on providing a performant and robust platform for your employees.
Affected services
Leapsome APIs
Updated
Jan 20 at 04:34pm CET
Our platform has been restored after experiencing a complex infrastructure incident that required Leapsome to go into unplanned maintenance mode. We understand this disruption impacted your operations and sincerely apologize for any inconvenience caused.
We continue to monitor the situation.
Affected services
Leapsome APIs
Updated
Jan 20 at 04:01pm CET
We want to inform you that we continue experiencing some technical difficulties with parts of our infrastructure. Our team is working diligently to resolve the issue as quickly as possible and ensure everything is back to normal soon.
We deeply apologize for any inconvenience this may cause and appreciate your understanding and patience. We’ll provide updates as they become available.
Affected services
Leapsome APIs
Updated
Jan 20 at 03:08pm CET
The team investigating decided to move the platform into a temporary maintenance mode to ensure data integrity and accelerate system recovery.
Affected services
Leapsome APIs
Created
Jan 20 at 02:55pm CET
We are aware of individual customers experiencing degraded platform performance and internal teams started to investigate.
Affected services
Leapsome APIs